<th id="frvp1"></th>

    小天使分享網

    通達信畫線顯示股價函數

    通達信指標中如何自動畫線

    自動畫線太多了,給你一個我看好的,源碼下面網址里有圖片演示.
    該指標能夠做到對前期高點和最近高點的連線、前期低點和最近低點的連線、阻力位和支撐位的平行直線的連線,可以說簡單易懂,一目了然。這類指標要用到未來函數,通常不做為買賣信號的參考。但該指標在一定周期內根據K線的走勢所畫的線已經成立,因此股價突破前高或頸線的點位還是比較可靠的,大家不妨在實戰中來驗證。所以,除了主圖以外,還編制了選股指標。
    指標中的實線為高、低點連線,虛線為阻力位和支撐位。
    該指標可以復制粘貼到任何主圖里。
    MA7:MA(C,7),COLORWHITE;
    MA14:MA(C,14),COLORYELLOW;
    MA25:MA(C,25),COLORFF00FF;
    MA120:MA(C,120),COLORFFCC66;
    QA:=REF(H,10)=HHV(H,2*10+1);
    QB:=BACKSET(QA,10+1);
    QC:=FILTER(QB,10) AND H=HHV(H,10+1);
    QD:=BARSLAST(QC);
    QE:=IF(QC,CURRBARSCOUNT,0);
    QF:=IF(QD,REF(QE,QD),QE);
    QG:=CONST(QF);
    QH:=REF(QF,QD+1);
    QW:=CONST(QH);
    DRAWLINE(CURRBARSCOUNT=QW,H,CURRBARSCOUNT=QG,H,1),COLORGREEN;
    DRAWLINE(CURRBARSCOUNT=QW,H,ISLASTBAR,REF(H,QW-1),1),COLOR0099FF,POINTDOT;
    DRAWLINE(CURRBARSCOUNT=QG,H,ISLASTBAR,REF(H,QG-1),1),COLOR0099FF,POINTDOT;
    QM:=INTPART(3*8/5);
    QR:=REF(H,QM)=HHV(H,2*QM+1);
    QT:=FILTER(QR,QM);
    QY:=BACKSET(QT,QM+1);
    QU:=FILTER(QY,QM);
    QI:=BACKSET(ISLASTBAR,BARSLAST(QU)+1);
    QP:=QI>REF(QI,1);
    DRAWLINE(QU,H,QP,H,1),COLORRED;
    QA1:=REF(L,8)=LLV(L,2*8+1);
    QB1:=BACKSET(QA1,8+1);
    QC1:=FILTER(QB1,8) AND L=LLV(L,8+1);
    QD1:=BARSLAST(QC1);
    QE1:=IF(QC1,CURRBARSCOUNT,0);
    QF1:=IF(QD1,REF(L,QD1),L);
    QG1:=IF(QD1,REF(QE1,QD1),QE1);
    QH1:=CONST(QG1);
    QW1:=REF(QF1,QD1+1);
    QM1:=REF(QG1,QD1+1);
    QR1:=CONST(QM1);
    DRAWLINE(CURRBARSCOUNT=QR1,L,CURRBARSCOUNT=QH1,L,1),COLORBLUE;
    DRAWLINE(CURRBARSCOUNT=QH1,L,ISLASTBAR,REF(L,QH1-1),1),COLORWHITE,POINTDOT;
    DRAWLINE(CURRBARSCOUNT=QR1,L,ISLASTBAR,REF(L,QR1-1),1),COLORWHITE,POINTDOT;
    QT1:=REF(L,QM)=LLV(L,2*QM+1);
    QY1:=FILTER(QT1,QM);
    QU1:=BACKSET(QY1,QM+1);
    QI1:=FILTER(QU1,QM);
    QP1:=BACKSET(ISLASTBAR,BARSLAST(QI1)+1);
    QJ1:=QP1>REF(QP1,1);
    DRAWLINE(QI1,L,QJ1,L,1),COLORRED;
    SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
    SR2:=FILTER(SR1,10);
    SR3:=BACKSET(SR2,10+1);
    HD:=FILTER(SR3,10);
    前高:=REF(H,BARSLAST(HD));
    DRAWICON(CROSS(C,前高),L-0.20,3);{突破前高的信號}

    求助通達信在主圖(K線圖)今日K線上的漲停價處顯示漲停價并畫一條線,類似附圖指標里的vol-tdx,...

    可以編寫在漲停處畫線但有些細節問題需要說明例如連續漲停怎么畫

    求助:通達信,股價斜下高點連線自動畫線公式,先謝了喲!

    將以下公式中的N換成5來用,你沒說具體的高點指什么高點,只好給你這個了。
    A1:=REF(H,N)=HHV(H,2*N+1);
    B1:=FILTER(A1,N);
    C1:=BACKSET(B1,N+1);
    D1:=FILTER(C1,N);
    A2:=REF(L,N)=LLV(L,2*N+1);
    B2:=FILTER(A2,N);
    C2:=BACKSET(B2,N+1);
    D2:=FILTER(C2,N);
    E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2;
    E2:=(H+L)/2;
    H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
    L1:=(D2 AND NOT(D1 AND E1<E2));
    H2:=D1 AND NOT(D2 AND E1>=E2);
    X1:=REF(BARSLAST(H1),1)+1;
    F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
    G1:=F1>REF(F1,1);
    I1:=BACKSET(G1,2);
    LD:=I1>REF(I1,1);
    L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
    X2:=REF(BARSLAST(L2),1)+1;
    F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
    G2:=F2>REF(F2,1);
    I2:=BACKSET(G2,2);
    HD:=I2>REF(I2,1);
    R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1);
    S1:=R1>REF(R1,1);
    T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1);
    U1:=T1>REF(T1,1);
    R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2);
    S2:=R2>REF(R2,1);
    T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);
    U2:=T2>REF(T2,1);
    短期壓力:DRAWLINE(S2,H,S1,H,1),LINETHICK2,COLORRED;
    短期支撐:DRAWLINE(U2,L,U1,L,1),LINETHICK2,COLORGREEN;

    在通達信上,如何自動劃線 如下圖

    這個問題要參考繪圖函數DRAWLINE的應用,舉例如下:
    DRAWLINE 繪制直線段
    在圖形上繪制直線段。
    用法:DRAWLINE(COND1,PRICE1,COND2,PRICE2,EXPAND)
    當COND1條件滿足時,在PRICE1位置畫直線起點,當COND2條件滿足時,在PRICE2位置畫直線終點,EXPAND為延長類型。
    例如: DRAWLINE(HIGH>=HHV(HIGH,20),HIGH,LOW<=LLV(LOW,20),LOW,1) 表示在創20天新高與創20天新低之間畫直線并且向右延長。

    由于你提供的信息有限,只能回答到這一步了,僅供參考。

    通達信如何在股價上選股 如我想選10--20元的股票,希望編一個選股公式?謝謝!

    c>=10 and c<=20;

    如何利用通達信軟件中的選股器選股

    通達信選股的步驟如下: 1.打開通達信股票軟件; 2.選擇“功能”菜單欄中的“選股器選項”; 3.選擇“條件選股”; 4.在打開的對話框中的“條件選股公式”的下拉菜單中選擇所需選股公式; 5.在“加入條件”文本框中輸入自己的條件,可輸入一個也可輸入多個; 6.點擊“改變范圍”按鈕選擇范圍; 7.點擊“選股人版塊”選擇版塊; 8.點擊“執行選股”選擇“條件股”; 9.點擊“保存方案”完成。